贪心算法 WOODEN STICKS 实例代码
Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute. (b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
Sample Output
2 1 3
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define N 5000;
struct node
{
int l;
int w;
int flag;
}sticks[5000];
int cmp(const void *p,const void *q)
{
struct node *a = (struct node *)p;
struct node *b = (struct node *)q;
if(a->l > b->l) return 1;
else if(a->l < b->l) return -1;
else return a->w > b->w ? 1 : -1;
}
int main()
{
int t,n,cnt,cl,cw;
int i,j;
scanf("%d",&t);
while(t--)
{
memset(sticks,0,sizeof(sticks));
scanf("%d",&n);
for( i = 0; i < n; i++)
scanf("%d %d",&sticks[i].l,&sticks[i].w);
qsort(sticks,n,sizeof(sticks[0]),cmp);
sticks[0].flag = 1;
cl = sticks[0].l;
cw = sticks[0].w;
cnt = 1;
for( j = 1; j < n; j++)
{
for( i = j; i < n; i++)
{
if(!sticks[i].flag&&sticks[i].l>=cl&&sticks[i].w>=cw)
{
cl = sticks[i].l;
cw = sticks[i].w;
sticks[i].flag = 1;
}
}
i = 1;
while(sticks[i].flag)
i++;
j = i;
if(j == n) break;
cl = sticks[j].l;
cw = sticks[j].w;
sticks[j].flag = 1;
cnt++;
}
printf("%d\n",cnt);
}
return 0;
}
题意:
我们要处理一些木棍,第一根的时间是1分钟,另外的,在长度为l,重为w的木棍后面的那根的长度为l', 重量w',只要l <=l' 并且w <= w',就不需要时间,否则需要1分钟,求如何安排处理木棍的顺序,才能使花的时间最少。
思路:
贪心算法。先把这些木棍按长度和重量都从小到大的顺序排列。cl和cw是第一根的长度和重量,依次比较后面的是不是比当前的cl,cw大,是的话把标志flag设为1,并跟新cl,cw。比较完后,再从前往后扫描,找到第一个标志位为0的,作为是第二批的最小的一根,计数器加一。把它的长度和重量作为当前的cl,cw,再循环往后比较。直到所有的都处理了。
您可能感兴趣的文章
- 01-10用贪心法求解背包问题的解决方法
- 01-10使用C++实现全排列算法的方法详解
- 01-10深入第K大数问题以及算法概要的详解
- 01-10深入N皇后问题的两个最高效算法的详解
- 01-10用C++实现DBSCAN聚类算法
- 01-10深入全排列算法及其实现方法
- 01-10全排列算法的非递归实现与递归实现的方法(C++)
- 01-10输出1000以内的素数的算法(实例代码)
- 01-10快速模式匹配算法(KMP)的深入理解
- 01-10海量数据处理系列之:用C++实现Bitmap算法
阅读排行
本栏相关
- 04-02c语言函数调用后清空内存 c语言调用
- 04-02func函数+在C语言 func函数在c语言中
- 04-02c语言的正则匹配函数 c语言正则表达
- 04-02c语言用函数写分段 用c语言表示分段
- 04-02c语言中对数函数的表达式 c语言中对
- 04-02c语言编写函数冒泡排序 c语言冒泡排
- 04-02c语言没有round函数 round c语言
- 04-02c语言分段函数怎么求 用c语言求分段
- 04-02C语言中怎么打出三角函数 c语言中怎
- 04-02c语言调用函数求fibo C语言调用函数求
随机阅读
- 01-10SublimeText编译C开发环境设置
- 01-10delphi制作wav文件的方法
- 01-11ajax实现页面的局部加载
- 08-05DEDE织梦data目录下的sessions文件夹有什
- 01-11Mac OSX 打开原生自带读写NTFS功能(图文
- 08-05织梦dedecms什么时候用栏目交叉功能?
- 01-10使用C语言求解扑克牌的顺子及n个骰子
- 08-05dedecms(织梦)副栏目数量限制代码修改
- 01-10C#中split用法实例总结
- 04-02jquery与jsp,用jquery